about summary refs log tree commit diff
path: root/make/examples/not-so-simple-header-auto/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'make/examples/not-so-simple-header-auto/default.nix')
-rw-r--r--make/examples/not-so-simple-header-auto/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/make/examples/not-so-simple-header-auto/default.nix b/make/examples/not-so-simple-header-auto/default.nix
index 9e84b0c28a..521af7e89f 100644
--- a/make/examples/not-so-simple-header-auto/default.nix
+++ b/make/examples/not-so-simple-header-auto/default.nix
@@ -1,11 +1,13 @@
-let {
+with import ../../lib;
 
-  inherit (import ../../lib) compileC findIncludes link;
+let {
 
   hello = link {programName = "hello"; objects = compileC {
     main = ./foo/hello.c;
     localIncludes = "auto";
   };};
 
+#  body = findIncludes {main = ./foo/hello.c;};
+
   body = [hello];
 }