summary refs log tree commit diff
path: root/infra/nixos/tazblog/configuration-packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/nixos/tazblog/configuration-packages.nix')
-rw-r--r--infra/nixos/tazblog/configuration-packages.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/infra/nixos/tazblog/configuration-packages.nix b/infra/nixos/tazblog/configuration-packages.nix
new file mode 100644
index 0000000000..d27d68b6d6
--- /dev/null
+++ b/infra/nixos/tazblog/configuration-packages.nix
@@ -0,0 +1,44 @@
+# Generated by stackage2nix 0.4.0 from "/nix/store/848g1i6w075hdan5w0i4zjc2vgrhig7f-stackage-all/lts-9.20.yaml"
+{ pkgs, haskellLib }:
+
+with haskellLib; self: super: {
+
+  # core packages
+  "array" = null;
+  "base" = null;
+  "binary" = null;
+  "bytestring" = null;
+  "containers" = null;
+  "deepseq" = null;
+  "directory" = null;
+  "filepath" = null;
+  "ghc-boot" = null;
+  "ghc-boot-th" = null;
+  "ghc-prim" = null;
+  "ghci" = null;
+  "hoopl" = null;
+  "hpc" = null;
+  "integer-gmp" = null;
+  "pretty" = null;
+  "process" = null;
+  "rts" = null;
+  "template-haskell" = null;
+  "time" = null;
+  "transformers" = null;
+  "unix" = null;
+  # break cycle: HUnit call-stack nanospec hspec QuickCheck test-framework xml text quickcheck-unicode test-framework-hunit test-framework-quickcheck2 hspec-core async hspec-expectations hspec-meta quickcheck-io silently temporary base-compat exceptions tasty clock tasty-quickcheck tasty-hunit optparse-applicative regex-tdfa parsec hspec-discover stringbuilder
+  "stringbuilder" = dontCheck super.stringbuilder;
+  "hspec-discover" = dontCheck super.hspec-discover;
+  "optparse-applicative" = dontCheck super.optparse-applicative;
+  "clock" = dontCheck super.clock;
+  "exceptions" = dontCheck super.exceptions;
+  "base-compat" = dontCheck super.base-compat;
+  "temporary" = dontCheck super.temporary;
+  "silently" = dontCheck super.silently;
+  "async" = dontCheck super.async;
+  "text" = dontCheck super.text;
+  "nanospec" = dontCheck super.nanospec;
+  # break cycle: statistics monad-par mwc-random vector-algorithms
+  "mwc-random" = dontCheck super.mwc-random;
+
+}