about summary refs log tree commit diff
path: root/home/modules/twitter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/twitter.nix')
-rw-r--r--home/modules/twitter.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/home/modules/twitter.nix b/home/modules/twitter.nix
index 9a6dc969b873..3cb2e90adc34 100644
--- a/home/modules/twitter.nix
+++ b/home/modules/twitter.nix
@@ -9,7 +9,15 @@
     TWITTER_WHOAMI = "glittershark1";
   };
 
-  programs.zsh.shellAliases = {
-    "mytl" = "t tl $TWITTER_WHOAMI";
+  programs.zsh = {
+    shellAliases = {
+      "mytl" = "t tl $TWITTER_WHOAMI";
+    };
+
+    functions = {
+      favelast = "t fave $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
+      rtlast = "t rt $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
+      tthread = "t reply $(t tl -l $TWITTER_WHOAMI | head -n1 | cut -d' ' -f1) $@";
+    };
   };
 }