about summary refs log tree commit diff
path: root/home/modules/twitter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/twitter.nix')
-rw-r--r--home/modules/twitter.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/modules/twitter.nix b/home/modules/twitter.nix
new file mode 100644
index 0000000000..9a6dc969b8
--- /dev/null
+++ b/home/modules/twitter.nix
@@ -0,0 +1,15 @@
+{ pkgs, lib, ... }:
+
+{
+  home.packages = with pkgs; [
+    t
+  ];
+
+  home.sessionVariables = {
+    TWITTER_WHOAMI = "glittershark1";
+  };
+
+  programs.zsh.shellAliases = {
+    "mytl" = "t tl $TWITTER_WHOAMI";
+  };
+}