about summary refs log tree commit diff
path: root/home/modules/i3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/i3.nix')
-rw-r--r--home/modules/i3.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/home/modules/i3.nix b/home/modules/i3.nix
index b4ffd202e07c..e3eea5f7d8d8 100644
--- a/home/modules/i3.nix
+++ b/home/modules/i3.nix
@@ -95,15 +95,13 @@ in {
             ''}";
 
             # Launching applications
-            "${mod}+u" =
-              let rofi = pkgs.writeShellScript "rofi" ''
+            "${mod}+u" = "exec ${pkgs.writeShellScript "rofi" ''
               rofi \
                 -modi 'combi' \
                 -combi-modi "window,drun,ssh,run" \
                 -font '${decorationFont}' \
                 -show combi
-            '';
-              in "exec ${rofi}";
+            ''}";
 
             # Passwords
             "${mod}+p" = "exec rofi-pass -font '${decorationFont}'";