about summary refs log tree commit diff
path: root/haskell-file/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'haskell-file/shell.nix')
-rw-r--r--haskell-file/shell.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/haskell-file/shell.nix b/haskell-file/shell.nix
index f2621d6eac5a..4d5b412a0884 100644
--- a/haskell-file/shell.nix
+++ b/haskell-file/shell.nix
@@ -1,9 +1,5 @@
-with import <nixpkgs> {};
-
-stdenv.mkDerivation {
-  name = "f-hs";
-  buildInputs = [
-    (pkgs.haskellPackages.ghcWithPackages (pkgs: [
-    ]))
-  ];
+let
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: [];
 }