about summary refs log tree commit diff
path: root/go/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'go/shell.nix')
-rw-r--r--go/shell.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/go/shell.nix b/go/shell.nix
index aab4123bff9a..e14bffae487c 100644
--- a/go/shell.nix
+++ b/go/shell.nix
@@ -1,9 +1,10 @@
 let
-  pkgs = import <nixpkgs> {};
+  briefcase = import <briefcase> {};
+  pkgs = briefcase.third_party.pkgs;
 in pkgs.mkShell {
-  buildInputs = [
-    pkgs.go
-    pkgs.goimports
-    pkgs.godef
+  buildInputs = with pkgs; [
+    go
+    goimports
+    godef
   ];
 }