about summary refs log tree commit diff
path: root/fun/idual/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/idual/default.nix')
-rw-r--r--fun/idual/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/fun/idual/default.nix b/fun/idual/default.nix
index e051f1c812..1ac87ab47f 100644
--- a/fun/idual/default.nix
+++ b/fun/idual/default.nix
@@ -12,8 +12,13 @@ let
       python.broadlink
     ];
   };
-in lib.fix (self: {
   package = python3Packages.buildPythonPackage opts;
   script  = python3Packages.buildPythonApplication opts;
-  python  = python3.withPackages (_: [ self.package ]);
-})
+in {
+  inherit script;
+  python  = python3.withPackages (_: [ package ]);
+  setAlarm = pkgs.writeShellScriptBin "set-alarm" ''
+    echo "setting an alarm for ''${1}"
+    ${pkgs.systemd}/bin/systemd-run --user --on-calendar="''${1} Europe/London" --unit=light-alarm.service
+  '';
+}