about summary refs log tree commit diff
path: root/fun/dt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/dt/default.nix')
-rw-r--r--fun/dt/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/fun/dt/default.nix b/fun/dt/default.nix
new file mode 100644
index 0000000000..4dbf00ede1
--- /dev/null
+++ b/fun/dt/default.nix
@@ -0,0 +1,14 @@
+{ depot, pkgs, ... }:
+
+let
+  stdenv = with pkgs; overrideCC clangStdenv clang_9;
+  abseil-cpp = pkgs.abseil-cpp.override { inherit stdenv; };
+in stdenv.mkDerivation {
+  name = "dt";
+  src = ./.;
+  nativeBuildInputs = [ pkgs.cmake ];
+  buildInputs = with pkgs; [
+    abseil-cpp
+    farmhash
+  ];
+}