about summary refs log tree commit diff
path: root/fun/🕰️/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/🕰️/default.nix')
-rw-r--r--fun/🕰️/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/fun/🕰️/default.nix b/fun/🕰️/default.nix
new file mode 100644
index 0000000000..d6fd5fc35e
--- /dev/null
+++ b/fun/🕰️/default.nix
@@ -0,0 +1,36 @@
+{ depot, ... }:
+
+let
+  inherit (depot.nix)
+    buildLisp
+    ;
+
+  lib = buildLisp.library {
+    name = "lib🕰️";
+    deps = [
+      depot.third_party.lisp.local-time
+    ];
+
+    srcs = [
+      ./lib.lisp
+    ];
+  };
+
+  bin = buildLisp.program {
+    name = "🕰️";
+    deps = [
+      depot.third_party.lisp.unix-opts
+      depot.lisp.klatre
+      (buildLisp.bundled "uiop")
+      lib
+    ];
+
+    srcs = [
+      ./bin.lisp
+    ];
+
+    main = "🕰️.bin:🚂";
+  };
+in bin // {
+  inherit lib;
+}