about summary refs log tree commit diff
path: root/externals/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/Makefile.am')
-rw-r--r--externals/Makefile.am79
1 files changed, 51 insertions, 28 deletions
diff --git a/externals/Makefile.am b/externals/Makefile.am
index c9bc05d71ee5..2fde866ea2b9 100644
--- a/externals/Makefile.am
+++ b/externals/Makefile.am
@@ -1,11 +1,11 @@
 # CWI ATerm
 
-ATERM = aterm-2.5
+ATERM = aterm-$(ATERM_VERSION)
 
 $(ATERM).tar.gz:
 	@echo "Nix requires the CWI ATerm library to build."
-	@echo "Please download version 2.5 from"
-	@echo "  http://nixos.org/tarballs/aterm-2.5.tar.gz"
+	@echo "Please download version $(ATERM_VERSION) from"
+	@echo "  http://nixos.org/tarballs/aterm-$(ATERM_VERSION).tar.gz"
 	@echo "and place it in the externals/ directory."
 	false
 
@@ -14,22 +14,19 @@ $(ATERM): $(ATERM).tar.gz
 	patch -d $(ATERM) -p1 < ./max-long.patch
 	patch -d $(ATERM) -p1 < ./sizeof.patch
 
-have-aterm:
-	$(MAKE) $(ATERM)
-	touch have-aterm
-
 if HAVE_ATERM
 build-aterm:
 else
-build-aterm: have-aterm
-	(pfx=`pwd` && \
-	cd $(ATERM) && \
-	CC="$(CC)" ./configure --prefix=$$pfx/inst-aterm \
-	  --disable-shared --enable-static && \
+build-aterm: $(ATERM)
+	(cd $(ATERM) && \
+	CC="$(CC)" ./configure --prefix=$(pkglibdir)/dummy --libdir=${pkglibdir} $(SUB_CONFIGURE_FLAGS) && \
 	$(MAKE) && \
-	$(MAKE) check && \
-	$(MAKE) install)
+	$(MAKE) check)
 	touch build-aterm
+
+install-exec-local:: build-aterm
+	cd $(ATERM) && make install
+	rm -rf "$(DESTDIR)/$(pkglibdir)/dummy"
 endif
 
 
@@ -47,30 +44,56 @@ $(BZIP2).tar.gz:
 $(BZIP2): $(BZIP2).tar.gz
 	gunzip < $(srcdir)/$(BZIP2).tar.gz | tar xvf -
 
-have-bzip2:
-	$(MAKE) $(BZIP2)
-	touch have-bzip2
-
 if HAVE_BZIP2
 build-bzip2:
 else
-build-bzip2: have-bzip2
-	(pfx=`pwd` && \
-	cd $(BZIP2) && \
+build-bzip2: $(BZIP2)
+	(cd $(BZIP2) && \
 	$(MAKE) && \
-	$(MAKE) install PREFIX=$$pfx/inst-bzip2)
+	$(MAKE) install PREFIX=$(abs_builddir)/inst-bzip2)
 	touch build-bzip2
 
-install:
+install-exec-local:: build-bzip2
 	mkdir -p $(DESTDIR)${bzip2_bin}
 	$(INSTALL_PROGRAM) $(bzip2_bin_test)/bzip2 $(bzip2_bin_test)/bunzip2 $(DESTDIR)${bzip2_bin}
 endif
 
 
-all: build-aterm build-bzip2
+# SQLite
+
+SQLITE = sqlite-$(SQLITE_VERSION)
+SQLITE_TAR = sqlite-amalgamation-$(SQLITE_VERSION).tar.gz
+
+$(SQLITE_TAR):
+	@echo "Nix requires the SQLite library to build."
+	@echo "Please download version $(SQLITE_VERSION) from"
+	@echo "  http://www.sqlite.org/$(SQLITE_TAR)"
+	@echo "and place it in the externals/ directory."
+	false
+
+$(SQLITE): $(SQLITE_TAR)
+	gzip -d < $(srcdir)/$(SQLITE_TAR) | tar xvf -
+
+if HAVE_SQLITE
+build-sqlite:
+else
+build-sqlite: $(SQLITE)
+	(cd $(SQLITE) && \
+	CC="$(CC)" ./configure --disable-static --prefix=$(pkglibdir)/dummy --libdir=${pkglibdir} $(SUB_CONFIGURE_FLAGS) && \
+	$(MAKE) )
+	touch build-sqlite
+
+install-exec-local:: build-sqlite
+	cd $(SQLITE) && make install
+	rm -rf "$(DESTDIR)/$(pkglibdir)/dummy"
+endif
+
+
+all: build-aterm build-bzip2 build-sqlite
 
-EXTRA_DIST = $(ATERM).tar.gz $(BZIP2).tar.gz max-long.patch sizeof.patch
+EXTRA_DIST = $(ATERM).tar.gz $(BZIP2).tar.gz $(SQLITE_TAR) max-long.patch sizeof.patch
 
-ext-clean:
-	$(RM) -f have-aterm build-aterm have-bzip2 build-bzip2
-	$(RM) -rf $(ATERM) $(BZIP2)
+clean:
+	$(RM) -f build-aterm build-bzip2 build-sqlite
+	$(RM) -rf $(ATERM) $(BZIP2) $(SQLITE)
+	$(RM) -rf inst-bzip2