about summary refs log tree commit diff
path: root/externals/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/Makefile.am')
-rw-r--r--externals/Makefile.am52
1 files changed, 4 insertions, 48 deletions
diff --git a/externals/Makefile.am b/externals/Makefile.am
index 29d0db0521..7f68eee6cc 100644
--- a/externals/Makefile.am
+++ b/externals/Makefile.am
@@ -1,46 +1,3 @@
-# Berkeley DB
-
-DB = db-4.5.20
-
-if OLD_DB_COMPAT
-
-$(DB).tar.gz:
-	@echo "Nix requires Berkeley DB to build."
-	@echo "Please download version 4.5.20 from"
-	@echo "  http://download-east.oracle.com/berkeley-db/db-4.5.20.tar.gz"
-	@echo "and place it in the externals/ directory."
-	false
-
-$(DB): $(DB).tar.gz
-	gunzip < $(srcdir)/$(DB).tar.gz | tar xvf -
-	(cd $(DB) && $(patch) -p1) < $(srcdir)/bdb-cygwin.patch
-
-have-db:
-	$(MAKE) $(DB)
-	touch have-db
-
-if HAVE_BDB
-build-db:
-else
-build-db: have-db
-	(pfx=`pwd` && \
-	cd $(DB)/build_unix && \
-	CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
-	 ../dist/configure --prefix=$$pfx/inst-bdb \
-	 --enable-cxx --disable-shared --disable-cryptography \
-         --disable-replication --disable-verify && \
-	$(MAKE) && \
-	$(MAKE) install_include install_lib)
-	touch build-db
-endif
-
-else
-
-build-db:
-
-endif
-
-
 # CWI ATerm
 
 ATERM = aterm-2.4.2-fixes-r2
@@ -107,11 +64,10 @@ install:
 endif
 
 
-all: build-db build-aterm build-bzip2
+all: build-aterm build-bzip2
 
-EXTRA_DIST = $(DB).tar.gz $(ATERM).tar.bz2 $(BZIP2).tar.gz \
-  bdb-cygwin.patch
+EXTRA_DIST = $(ATERM).tar.bz2 $(BZIP2).tar.gz
 
 ext-clean:
-	$(RM) -f have-db build-db have-aterm build-aterm have-bzip2 build-bzip2
-	$(RM) -rf $(DB) $(ATERM) $(BZIP2)
+	$(RM) -f have-aterm build-aterm have-bzip2 build-bzip2
+	$(RM) -rf $(ATERM) $(BZIP2)