about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index c6b140329972..685a37ec2b59 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -1,8 +1,9 @@
-{ pkgs, ... }:
+{ pkgs, depot, ... }:
 
 let
   inherit (builtins) path;
-  inherit (pkgs) emacs26 emacsPackagesNgGen writeShellScript writeShellScriptBin;
+  inherit (depot.third_party) emacsPackagesGen emacs27;
+  inherit (pkgs) writeShellScript writeShellScriptBin;
   inherit (pkgs.lib.strings) makeBinPath;
 
   emacsBinPath = makeBinPath (with pkgs; [
@@ -17,7 +18,7 @@ let
     xorg.xset
   ]);
 
-  emacsWithPackages = (emacsPackagesNgGen emacs26).emacsWithPackages;
+  emacsWithPackages = (emacsPackagesGen emacs27).emacsWithPackages;
 
   wpcarrosEmacs = emacsWithPackages (epkgs:
     (with epkgs.elpaPackages; [
@@ -32,6 +33,7 @@ let
       ts
       vterm
       base16-theme
+      password-store
       ivy-pass
       clipmon # TODO: Prefer an Emacs client for clipmenud.
       protobuf-mode # TODO: Determine if this is coming from google-emacs.
@@ -57,7 +59,6 @@ let
       parsec
       magit-popup
       direnv
-      emr
       ivy-prescient
       all-the-icons
       all-the-icons-ivy
@@ -109,7 +110,6 @@ let
       counsel
       flycheck
       ivy
-      magit
     ]));
 
   vendorDir = path {