about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index e8d52c34cc9d..126894a8fc3a 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -148,6 +148,21 @@ let
       "$@"
   '';
 in {
+  inherit initEl;
+
+  # I need to start my Emacs from CI without the call to `--load ${initEl}`.
+  runScript = script: pkgs.writeShellScript "run-emacs-script" ''
+    export BRIEFCASE=$HOME/briefcase
+    export PATH="${emacsBinPath}:$PATH"
+    export EMACSLOADPATH="${wpcDir}:${vendorDir}:${wpcarrosEmacs.deps}/share/emacs/site-lisp"
+    exec ${wpcarrosEmacs}/bin/emacs \
+      --no-site-file \
+      --no-site-lisp \
+      --no-init-file \
+      --script ${script} \
+      "$@"
+  '';
+
   # Use `nix-env -f '<briefcase>' emacs.glinux` to install `wpcarro-emacs` on
   # gLinux machines. This will ensure that X and GL linkage behaves as expected.
   glinux = withEmacsPath "/usr/bin/google-emacs";