about summary refs log tree commit diff
path: root/editline.nix
diff options
context:
space:
mode:
Diffstat (limited to 'editline.nix')
-rw-r--r--editline.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/editline.nix b/editline.nix
new file mode 100644
index 000000000000..dc44c7d8705f
--- /dev/null
+++ b/editline.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchFromGitHub, autoreconfHook }:
+
+stdenv.mkDerivation rec {
+  name = "editline-${version}";
+  version = "1.16.0";
+  src = fetchFromGitHub {
+    owner = "troglobit";
+    repo = "editline";
+    rev = version;
+    sha256 = "0a751dp34mk9hwv59ss447csknpm5i5cgd607m3fqf24rszyhbf2";
+  };
+
+  nativeBuildInputs = [ autoreconfHook ];
+
+  dontDisableStatic = true;
+
+  meta = with stdenv.lib; {
+    homepage = http://troglobit.com/editline.html;
+    description = "A readline() replacement for UNIX without termcap (ncurses)";
+    license = licenses.bsdOriginal;
+    maintainers = with maintainers; [ dtzWill ];
+    platforms = platforms.all;
+  };
+}