about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index 65f1f3f44134..5bd256658bdf 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -1,13 +1,12 @@
 DOCBOOK_DTD = /nix/current/xml/dtd/docbook
 DOCBOOK_XSL = /nix/current/xml/xsl/docbook
-XML = /usr/share/doc/packages/sp/html-xml/xml.soc
 
 SOURCES = book.xml introduction.xml installation.xml nix-reference.xml \
  troubleshooting.xml bugs.xml
 
 book.is-valid: $(SOURCES)
-	SP_CHARSET_FIXED=YES SP_ENCODING=XML \
-	nsgmls -wxml -c $(XML) -c $(DOCBOOK_DTD)/docbook.cat -ges $<
+	SGML_CATALOG_FILES=$(DOCBOOK_DTD)/docbook.cat \
+	xmllint --catalogs --noout --valid book.xml
 	touch $@
 
 man1_MANS = nix.1 fix.1