about summary refs log tree commit diff
path: root/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/desktop.nix b/desktop.nix
index bb3041f1c56f..6ff41cbfdedb 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -2,8 +2,7 @@
 
 { config, lib, pkgs, ... }:
 
-let wallpapers = import ./pkgs/wallpapers.nix;
-    emacs = import ./emacs.nix { inherit pkgs; };
+let emacs = import ./emacs.nix { inherit pkgs; };
 in {
   # Configure basic X-server stuff:
   services.xserver = {
@@ -52,7 +51,7 @@ in {
     description = "Randomly set wallpaper via feh";
     serviceConfig = {
       Type             = "oneshot";
-      WorkingDirectory = "${wallpapers}/share/wallpapers";
+      WorkingDirectory = "${pkgs.wallpapers}/share/wallpapers";
 
       # Manually shuffle because feh's --randomize option can't be restricted to
       # just certain file types.