about summary refs log tree commit diff
path: root/deploy/cloud_run.nix
diff options
context:
space:
mode:
Diffstat (limited to 'deploy/cloud_run.nix')
-rw-r--r--deploy/cloud_run.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/deploy/cloud_run.nix b/deploy/cloud_run.nix
new file mode 100644
index 000000000000..70be4040c36b
--- /dev/null
+++ b/deploy/cloud_run.nix
@@ -0,0 +1,18 @@
+{
+  pkgs ? import <nixpkgs> {},
+  depot ? import <depot> {},
+  ...
+}:
+
+pkgs.dockerTools.buildLayeredImage {
+  name = "gemma";
+  tag = "latest";
+  config.ExposedPorts = {
+    "4242" = {};
+  };
+  config.Env = [
+    "GEMMA_CONFIG=${./config.lisp}"
+  ];
+  config.Cmd = [ "${depot.fun.gemma}/bin/gemma" ];
+  maxLayers = 120;
+}