about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index ee22077574..cc2ebcabcf 100644
--- a/default.nix
+++ b/default.nix
@@ -5,7 +5,7 @@
 # This makes packages accessible via the Nixery instance that is configured to
 # use this repository as its nixpkgs source.
 
-{ ... }@args:
+{ nixpkgsBisectPath ? null, ... }@args:
 
 with builtins;
 
@@ -24,6 +24,13 @@ let
     # Pass third_party as 'pkgs' (for compatibility with external
     # imports for certain subdirectories)
     pkgs = depot.third_party.nixpkgs;
+
+    # Pass arguments passed to the entire depot through, for packages
+    # that would like to add functionality based on this.
+    #
+    # Note that it is intended for exceptional circumstance, such as
+    # debugging by bisecting nixpkgs.
+    externalArgs = args;
   };
 
   readTree' = import ./nix/readTree {};