about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index fd02dfbde9..1cf62e94af 100644
--- a/default.nix
+++ b/default.nix
@@ -108,8 +108,8 @@ in readTree.fix(self: (readDepot {
   });
 
   # Derivation that gcroots all depot targets.
-  ci.gcroot = self.third_party.nixpkgs.symlinkJoin {
+  ci.gcroot = with self.third_party.nixpkgs; makeSetupHook {
     name = "depot-gcroot";
-    paths = self.ci.targets;
-  };
+    deps = self.ci.targets;
+  } emptyFile;
 })