about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index 919082981e1e..000000000000
--- a/default.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-{ nixpkgs ? <nixpkgs>, system ? builtins.currentSystem }:
-
-with import nixpkgs { inherit system; };
-
-let nix = nixUnstable; in
-
-runCommandCC "nix-repl"
-  { buildInputs = [ pkgconfig readline nix boehmgc ]; }
-  ''
-    mkdir -p $out/bin
-    g++ -O3 -Wall -std=c++14 \
-      -o $out/bin/nix-repl ${./nix-repl.cc} \
-      $(pkg-config --cflags nix-main) \
-      -lnixformat -lnixutil -lnixstore -lnixexpr -lnixmain -lreadline -lgc \
-      -DNIX_VERSION=\"${(builtins.parseDrvName nix.name).version}\"
-  ''