about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix45
1 files changed, 12 insertions, 33 deletions
diff --git a/default.nix b/default.nix
index 861ae6beee6f..36dba2915b4a 100644
--- a/default.nix
+++ b/default.nix
@@ -1,38 +1,17 @@
-# At the time of this writing, this configuration was taken from @tazjin's
-# default.nix from his depot. I've added, changed, and removed that parts that I
-# don't need, and this is what remains.
-{ ... }@args:
-
-with builtins;
+{ ... }:
 
 let
-  fix = f: let x = f x; in x;
-
-  # Global configuration that all packages are called with.
-  config = self: {
-    inherit self;
-    pkgs = import <nixpkgs> {};
-    depot = import <depot> {};
+  readTree = import <depot/nix/readTree> {} {
+    pkgs      = import <nixpkgs> {};
+    depot     = import <depot> {};
     briefcase = import <briefcase> {};
   };
-
-  readTree' = import <depot/nix/readTree> {};
-
-  # TODO: Find a better way to expose entire monorepo without introducing
-  # "infinite recursion".
-  localPkgs = readTree: {
-    nixos = readTree ./nixos;
-    blog = readTree ./blog;
-    lisp = readTree ./lisp;
-    gopkgs = readTree ./gopkgs;
-    monzo_ynab = readTree ./monzo_ynab;
-    third_party = readTree ./third_party;
-    tools = readTree ./tools;
-  };
-in fix(self: {
-  config = config self;
+in {
+  nixos       = readTree ./nixos;
+  blog        = readTree ./blog;
+  lisp        = readTree ./lisp;
+  gopkgs      = readTree ./gopkgs;
+  monzo_ynab  = readTree ./monzo_ynab;
+  third_party = readTree ./third_party;
+  tools       = readTree ./tools;
 }
-
-# Add local packages as structured by readTree
-// (localPkgs (readTree' (self.config // { inherit (self) lib; })))
-)