about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 000000000000..f73c537abd43
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,8 @@
+{ nixpkgs ? import <nixpkgs> {}, compiler ? "ghc865" }:
+let
+  inherit (nixpkgs) pkgs;
+  all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
+  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
+  xanthous = pkgs.haskellPackages.callPackage ./xanthous.nix {};
+in
+xanthous // { inherit hie; }