about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 8690325e5289..919082981e1e 100644
--- a/default.nix
+++ b/default.nix
@@ -4,13 +4,13 @@ with import nixpkgs { inherit system; };
 
 let nix = nixUnstable; in
 
-runCommand "nix-repl"
-  { buildInputs = [ readline nix boehmgc ]; }
+runCommandCC "nix-repl"
+  { buildInputs = [ pkgconfig readline nix boehmgc ]; }
   ''
     mkdir -p $out/bin
-    g++ -O3 -Wall -std=c++0x \
+    g++ -O3 -Wall -std=c++14 \
       -o $out/bin/nix-repl ${./nix-repl.cc} \
-      -I${nix}/include/nix \
+      $(pkg-config --cflags nix-main) \
       -lnixformat -lnixutil -lnixstore -lnixexpr -lnixmain -lreadline -lgc \
       -DNIX_VERSION=\"${(builtins.parseDrvName nix.name).version}\"
   ''