about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index 92ab494c42..0000000000
--- a/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-# Nix derivation to build a release version of journaldriver.
-#
-# Note: This does not currently use Carnix due to an issue with
-# linking against the `systemd.dev` derivation for libsystemd.
-
-{ pkgs ? import <nixpkgs> {}
-, doCheck ? true }:
-
-with pkgs; rustPlatform.buildRustPackage {
-  inherit doCheck;
-
-  name        = "journaldriver";
-  version     = "1.1.0";
-  cargoSha256 = "03rq96hzv97wh2gbzi8sz796bqgh6pbpvdn0zy6zgq2f2sgkavsl";
-
-  src = ./.;
-
-  buildInputs = [ pkgconfig openssl systemd.dev ];
-}