about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index f73c537abd43..7cf9f4beb451 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,8 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "ghc865" }:
+{ nixpkgs ? import ./nixpkgs.nix {}, compiler ? "ghc865" }:
 let
   inherit (nixpkgs) pkgs;
   all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
   hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
-  xanthous = pkgs.haskellPackages.callPackage ./xanthous.nix {};
+  xanthous = pkgs.haskellPackages.callPackage (import ./pkg.nix { inherit nixpkgs; }) {};
 in
 xanthous // { inherit hie; }