about summary refs log tree commit diff
path: root/corp/website/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corp/website/default.nix')
-rw-r--r--corp/website/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/corp/website/default.nix b/corp/website/default.nix
new file mode 100644
index 0000000000..2011e2a376
--- /dev/null
+++ b/corp/website/default.nix
@@ -0,0 +1,37 @@
+{ depot, pkgs, ... }:
+
+
+let
+  # https://developers.google.com/search/docs/advanced/structured-data/logo
+  structuredData = {
+    "@context" = "https://schema.org";
+    "@type" = "Organisation";
+    url = "https://tvl.su";
+    logo = "https://static.tvl.fyi/${depot.web.static.drvHash}/logo-animated.svg";
+  };
+  index = depot.web.tvl.template {
+    title = "TVL (The Virus Lounge) - Software consulting";
+    content = builtins.readFile ./content.md;
+    extraFooter = "\n|\n © ООО ТВЛ";
+
+    # TODO(tazjin): The `.tvl-logo` thing can probably go in the shared CSS.
+    extraHead = ''
+      <meta name="description" content="TVL provides technology consulting for monorepos, Nix, and other SRE/DevOps/Software Engineering topics.">
+      <script type="application/ld+json">
+        ${builtins.toJSON structuredData}
+      </script>
+      <style>
+        .tvl-logo {
+          width: 60%;
+          display: block;
+          margin-left: auto;
+          margin-right: auto;
+        }
+      </style>
+    '';
+  };
+in
+pkgs.runCommandNoCC "corp-website" { } ''
+  mkdir $out
+  cp ${index} $out/index.html
+''