about summary refs log tree commit diff
path: root/corp/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'corp/tvixbolt/Cargo.toml')
-rw-r--r--corp/tvixbolt/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/corp/tvixbolt/Cargo.toml b/corp/tvixbolt/Cargo.toml
new file mode 100644
index 0000000000..123d49e109
--- /dev/null
+++ b/corp/tvixbolt/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "tvixbolt"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+yew = "0.19.3"
+codemap = "0.1.3"
+web-sys = "*"
+
+[dependencies.rnix]
+git = "https://github.com/nix-community/rnix-parser.git"
+rev = "97b438e34be5211a4b48aeed9cc3ded489b4d6da"
+
+[dependencies.tvix-eval]
+path = "../tvix-eval/tvix/eval"
+default-features = false
+features = [ "disassembler" ]