about summary refs log tree commit diff
path: root/corepkgs/nix-pull/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/nix-pull/Makefile.am')
-rw-r--r--corepkgs/nix-pull/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/corepkgs/nix-pull/Makefile.am b/corepkgs/nix-pull/Makefile.am
new file mode 100644
index 000000000000..91adb4853f3b
--- /dev/null
+++ b/corepkgs/nix-pull/Makefile.am
@@ -0,0 +1,11 @@
+all-local: builder.sh
+
+install-exec-local:
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs/nix-pull
+	$(INSTALL_DATA) default.nix $(DESTDIR)$(datadir)/nix/corepkgs/nix-pull
+	$(INSTALL_PROGRAM) builder.sh $(DESTDIR)$(datadir)/nix/corepkgs/nix-pull
+
+include ../../substitute.mk
+
+EXTRA_DIST = default.nix builder.sh.in