about summary refs log tree commit diff
path: root/corepkgs/nar.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/nar.nix')
-rw-r--r--corepkgs/nar.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/corepkgs/nar.nix b/corepkgs/nar.nix
deleted file mode 100644
index 61b3fc6772c4..000000000000
--- a/corepkgs/nar.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-with import <nix/config.nix>;
-
-let
-
-  builder = builtins.toFile "nar.sh"
-    ''
-      export PATH=${nixBinDir}:${coreutils}
-
-      if [ $compressionType = xz ]; then
-        ext=.xz
-        compressor="| ${xz} -7"
-      elif [ $compressionType = bzip2 ]; then
-        ext=.bz2
-        compressor="| ${bzip2}"
-      else
-        ext=
-        compressor=
-      fi
-
-      echo "packing ‘$storePath’..."
-      mkdir $out
-      dst=$out/tmp.nar$ext
-
-      set -o pipefail
-      eval "nix-store --dump \"$storePath\" $compressor > $dst"
-
-      hash=$(nix-hash --flat --type $hashAlgo --base32 $dst)
-      echo -n $hash > $out/nar-compressed-hash
-
-      mv $dst $out/$hash.nar$ext
-    '';
-
-in
-
-{ storePath, hashAlgo, compressionType }:
-
-derivation {
-  name = "nar";
-  system = builtins.currentSystem;
-  builder = shell;
-  args = [ "-e" builder ];
-  inherit storePath hashAlgo compressionType;
-
-  # Remote machines may not have ${nixBinDir} or ${coreutils} in the same prefixes
-  preferLocalBuild = true;
-
-  inherit chrootDeps;
-}