about summary refs log tree commit diff
path: root/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/fetchurl.nix')
-rw-r--r--corepkgs/fetchurl.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/corepkgs/fetchurl.nix b/corepkgs/fetchurl.nix
index c85c007ff218..758212015aee 100644
--- a/corepkgs/fetchurl.nix
+++ b/corepkgs/fetchurl.nix
@@ -1,3 +1,5 @@
+with import <nix/config.nix>;
+
 # Argh, this thing is duplicated (more-or-less) in Nixpkgs.  Need to
 # find a way to combine them.
 
@@ -19,5 +21,5 @@ derivation {
   outputHash = if outputHash != "" then outputHash else
       if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
   
-  inherit system url;
+  inherit system url curl;
 }