about summary refs log tree commit diff
path: root/corepkgs/config.nix.in
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/config.nix.in')
-rw-r--r--corepkgs/config.nix.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/corepkgs/config.nix.in b/corepkgs/config.nix.in
index a5ec83b9ea0c..8918f4ddde8d 100644
--- a/corepkgs/config.nix.in
+++ b/corepkgs/config.nix.in
@@ -2,7 +2,7 @@ let
   fromEnv = var: def:
     let val = builtins.getEnv var; in
     if val != "" then val else def;
-in {
+in rec {
   perl = "@perl@";
   shell = "@bash@";
   coreutils = "@coreutils@";
@@ -14,4 +14,14 @@ in {
   tr = "@tr@";
   curl = "@curl@";
   nixBinDir = fromEnv "NIX_BIN_DIR" "@bindir@";
+  nixPrefix = "@prefix@";
+
+  # If Nix is installed in the Nix store, then automatically add it as
+  # a dependency to the core packages. This ensures that they work
+  # properly in a chroot.
+  chrootDeps =
+    if dirOf nixPrefix == builtins.storeDir then
+      [ (builtins.storePath nixPrefix) ]
+    else
+      [ ];
 }