about summary refs log tree commit diff
path: root/corepkgs/channels/unpack.sh.in
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/channels/unpack.sh.in')
-rw-r--r--corepkgs/channels/unpack.sh.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/corepkgs/channels/unpack.sh.in b/corepkgs/channels/unpack.sh.in
new file mode 100644
index 000000000000..f349f3da3862
--- /dev/null
+++ b/corepkgs/channels/unpack.sh.in
@@ -0,0 +1,24 @@
+#! @shell@ -e
+
+export PATH=/bin:/usr/bin # !!! impure
+
+mkdir $out
+mkdir $out/tmp
+cd $out/tmp
+
+expr=$out/default.nix
+echo '[' > $expr
+
+nr=0
+for i in $inputs; do
+    echo "unpacking $i"
+    @bunzip2@ < $i | tar xvf -
+    mv * ../$nr # !!! hacky
+    echo "(import ./$nr)" >> $expr
+    nr=$(($nr + 1))
+done
+
+echo ']' >> $expr
+
+cd ..
+rmdir tmp
\ No newline at end of file