about summary refs log tree commit diff
path: root/corepkgs/channels/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/channels/Makefile.am')
-rw-r--r--corepkgs/channels/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/corepkgs/channels/Makefile.am b/corepkgs/channels/Makefile.am
new file mode 100644
index 000000000000..1bf73f7f4cb8
--- /dev/null
+++ b/corepkgs/channels/Makefile.am
@@ -0,0 +1,11 @@
+all-local: unpack.sh
+
+install-exec-local:
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs/channels
+	$(INSTALL_DATA) unpack.nix $(DESTDIR)$(datadir)/nix/corepkgs/channels
+	$(INSTALL_PROGRAM) unpack.sh $(DESTDIR)$(datadir)/nix/corepkgs/channels
+
+include ../../substitute.mk
+
+EXTRA_DIST = default.nix unpack.sh.in