about summary refs log tree commit diff
path: root/corepkgs/buildenv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/buildenv/default.nix')
-rw-r--r--corepkgs/buildenv/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/corepkgs/buildenv/default.nix b/corepkgs/buildenv/default.nix
index a5452db5ea89..36dd9d0c6a0a 100644
--- a/corepkgs/buildenv/default.nix
+++ b/corepkgs/buildenv/default.nix
@@ -4,9 +4,11 @@ derivation {
   name = "user-environment";
   system = system;
   builder = ./builder.pl;
-  derivations = derivations;
+  
   manifest = manifest;
 
   # !!! grmbl, need structured data for passing this in a clean way.
+  paths = derivations;
   active = map (x: if x ? meta && x.meta ? active then x.meta.active else "true") derivations;
+  priority = map (x: if x ? meta && x.meta ? priority then x.meta.priority else "5") derivations;
 }