about summary refs log tree commit diff
path: root/corepkgs/buildenv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/buildenv.nix')
-rw-r--r--corepkgs/buildenv.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/corepkgs/buildenv.nix b/corepkgs/buildenv.nix
new file mode 100644
index 000000000000..c52a0ea93d35
--- /dev/null
+++ b/corepkgs/buildenv.nix
@@ -0,0 +1,28 @@
+with import <nix/config.nix>;
+
+{ derivations, manifest }:
+
+derivation {
+  name = "user-environment";
+  system = builtins.currentSystem;
+  builder = perl;
+  args = [ "-w" ./buildenv.pl ];
+
+  manifest = manifest;
+
+  # !!! grmbl, need structured data for passing this in a clean way.
+  derivations =
+    map (d:
+      [ (d.meta.active or "true")
+        (d.meta.priority or 5)
+        (builtins.length d.outputs)
+      ] ++ map (output: builtins.getAttr output d) d.outputs)
+      derivations;
+
+  # Building user environments remotely just causes huge amounts of
+  # network traffic, so don't do that.
+  preferLocalBuild = true;
+
+  # Don't build in a chroot because Nix's dependencies may not be there.
+  __noChroot = true;
+}