about summary refs log tree commit diff
path: root/corepkgs/buildenv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/buildenv.nix')
-rw-r--r--corepkgs/buildenv.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/corepkgs/buildenv.nix b/corepkgs/buildenv.nix
index 923778379263..c52a0ea93d35 100644
--- a/corepkgs/buildenv.nix
+++ b/corepkgs/buildenv.nix
@@ -13,7 +13,7 @@ derivation {
   # !!! grmbl, need structured data for passing this in a clean way.
   derivations =
     map (d:
-      [ (if d.meta.active or true then "1" else "0")
+      [ (d.meta.active or "true")
         (d.meta.priority or 5)
         (builtins.length d.outputs)
       ] ++ map (output: builtins.getAttr output d) d.outputs)