about summary refs log tree commit diff
path: root/corepkgs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/Makefile.am')
-rw-r--r--corepkgs/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/corepkgs/Makefile.am b/corepkgs/Makefile.am
index 7f43a700e734..86d7027ed06e 100644
--- a/corepkgs/Makefile.am
+++ b/corepkgs/Makefile.am
@@ -1,11 +1,11 @@
-SUBDIRS = channels
-
 all-local: config.nix
 
+files = nar.nix buildenv.nix buildenv.pl unpack-channel.nix unpack-channel.sh
+
 install-exec-local:
 	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs
-	$(INSTALL_DATA) config.nix $(srcdir)/nar.nix $(srcdir)/buildenv.nix $(srcdir)/buildenv.pl $(DESTDIR)$(datadir)/nix/corepkgs
+	$(INSTALL_DATA) config.nix $(files) $(DESTDIR)$(datadir)/nix/corepkgs
 
 include ../substitute.mk
 
-EXTRA_DIST = config.nix.in nar.nix buildenv.nix buildenv.pl
+EXTRA_DIST = config.nix.in $(files)