about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d1cfe2fbf261..b5c24743449f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,12 @@ if test "$sys_name" = "cygwin"; then
     AC_DEFINE(CANNOT_DELETE_OPEN_FILES, 1, [Whether it is impossible to delete open files.])
 fi
 
+# Solaris-specific stuff.
+if test "$sys_name" = "sunos"; then
+    # Solaris requires -lsocket -lnsl for network functions
+    ADDITIONAL_NETWORK_LIBS="-lsocket -lnsl"
+    AC_SUBST(ADDITIONAL_NETWORK_LIBS)
+fi
 
 AC_PROG_CC
 AC_PROG_CXX