about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2ce755d66a58..f9f3376b52d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,13 +27,10 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
      linux-gnu*)
 	# For backward compatibility, strip the `-gnu' part.
 	system="$machine_name-linux";;
-     freebsd*)
-	# Strip the version number (e.g. freebsd8.2).
-	system="$machine_name-freebsd";;
      *)
         # Strip the version number from names such as `gnu0.3',
         # `darwin10.2.0', etc.
-	system="$machine_name-`echo $host_os | "$SED" -e's/[0-9.]\+$//g'`";;
+	system="$machine_name-`echo $host_os | "$SED" -e's/[0-9.]*$//g'`";;
    esac])
 
 AC_MSG_RESULT($system)