about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ac37456ae5fe..24a95ce56f3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,14 +196,6 @@ if test "$gc" = yes; then
 fi
 
 
-# Check for readline, needed by "nix repl".
-AX_LIB_READLINE
-if test "$ax_cv_lib_readline" != "no"; then
-  have_readline=1
-fi
-AC_SUBST(HAVE_READLINE, [$have_readline])
-
-
 AC_ARG_ENABLE(init-state, AC_HELP_STRING([--disable-init-state],
   [do not initialise DB etc. in `make install']),
   init_state=$enableval, init_state=yes)
@@ -248,6 +240,12 @@ fi
 AC_SUBST(tarFlags)
 
 
+AC_ARG_WITH(sandbox-shell, AC_HELP_STRING([--with-sandbox-shell=PATH],
+  [path of a statically-linked shell to use as /bin/sh in sandboxes]),
+  sandbox_shell=$withval)
+AC_SUBST(sandbox_shell)
+
+
 # Expand all variables in config.status.
 test "$prefix" = NONE && prefix=$ac_default_prefix
 test "$exec_prefix" = NONE && exec_prefix='${prefix}'