about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index fb2228a6f1..7a83d8f355 100644
--- a/configure.ac
+++ b/configure.ac
@@ -237,15 +237,7 @@ AM_CONDITIONAL(INIT_STATE, test "$init_state" = "yes")
 
 
 # Setuid installations.
-AC_CHECK_FUNC(setresuid, [HAVE_SETRESUID=1], [HAVE_SETRESUID=])
-if test "$HAVE_SETRESUID" = "1"; then
-    AC_DEFINE(HAVE_SETRESUID, 1, [whether we have setresuid()])
-fi
-
-AC_CHECK_FUNC(setreuid, [HAVE_SETREUID=1], [HAVE_SETREUID=])
-if test "$HAVE_SETREUID" = "1"; then
-    AC_DEFINE(HAVE_SETREUID, 1, [whether we have setreuid()])
-fi
+AC_CHECK_FUNCS([setresuid setreuid lchown])
 
 
 # This is needed if ATerm, Berkeley DB or bzip2 are static libraries,