about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3cc8eeea2..2ce755d66a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,8 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
   [case "$host_cpu" in
      i*86)
         machine_name="i686";;
+     amd64)
+        machine_name="x86_64";;
      *)
         machine_name="$host_cpu";;
    esac
@@ -25,6 +27,9 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
      linux-gnu*)
 	# For backward compatibility, strip the `-gnu' part.
 	system="$machine_name-linux";;
+     freebsd*)
+	# Strip the version number (e.g. freebsd8.2).
+	system="$machine_name-freebsd";;
      *)
         # Strip the version number from names such as `gnu0.3',
         # `darwin10.2.0', etc.