about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
index 8ace418cdca5..1af903fb255c 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -6,6 +6,7 @@
 
 let rust-overlay = import nixpkgs-mozilla/rust-overlay.nix;
     unstable = import <nixos-unstable> { config.allowUnfree = true; };
+    nixfd = import pkgs/nixfd.nix;
 in {
   imports =
     [ # Include the results of the hardware scan.
@@ -31,6 +32,7 @@ in {
   environment.systemPackages = with pkgs; [
     curl gnumake unzip openjdk gcc htop tree direnv tmux fish ripgrep
     gnupg pass git manpages stdmanpages latest.rustChannels.stable.rust
+    nixfd
   ];
 
   # Enable the X11 windowing system.