about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/configuration.nix b/configuration.nix
index 76466c7e39f5..27c55b47a011 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -24,14 +24,16 @@
   boot.kernelModules = [ "snd-seq" "snd-rawmidi" ];
   hardware.pulseaudio.package = pkgs.pulseaudioFull;
 
-  # Don't use ISP's DNS servers:
-  networking.nameservers = [
-    "1.1.1.1"
-    "1.0.0.1"
-  ];
+  networking = {
+    # Don't use ISP's DNS servers:
+    nameservers = [
+      "1.1.1.1"
+      "1.0.0.1"
+    ];
 
-  # Open Chromecast-related ports
-  firewall.allowedTCPPorts = [ 5556 5558 ];
+    # Open Chromecast-related ports
+    firewall.allowedTCPPorts = [ 5556 5558 ];
+  };
 
   # Configure emacs:
   # (actually, that's a lie, this only installs emacs!)