about summary refs log tree commit diff
path: root/common-lisp/cl-colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common-lisp/cl-colors.nix')
-rw-r--r--common-lisp/cl-colors.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/common-lisp/cl-colors.nix b/common-lisp/cl-colors.nix
new file mode 100644
index 000000000000..cff40fef342d
--- /dev/null
+++ b/common-lisp/cl-colors.nix
@@ -0,0 +1,20 @@
+{ tpkgs ? (import (builtins.fetchGit "https://git.tazj.in/") {}), ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/tpapp/cl-colors.git";
+    rev = "827410584553f5c717eec6182343b7605f707f75";
+  };
+in tpkgs.nix.buildLisp.library {
+  name = "cl-colors";
+  deps = with tpkgs.third_party.lisp; [
+    alexandria
+    (import ./let-plus.nix {})
+  ];
+  srcs = [
+    "${src}/package.lisp"
+    "${src}/colors.lisp"
+    "${src}/colornames.lisp"
+    "${src}/hexcolors.lisp"
+  ];
+}