about summary refs log tree commit diff
path: root/ci/pipelines/pre-receive.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci/pipelines/pre-receive.nix')
-rw-r--r--ci/pipelines/pre-receive.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/ci/pipelines/pre-receive.nix b/ci/pipelines/pre-receive.nix
new file mode 100644
index 000000000000..9a30f271ed45
--- /dev/null
+++ b/ci/pipelines/pre-receive.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }:
+
+let
+  pipeline.steps = [
+    {
+      key = "lint";
+      command = "${pkgs.git-secrets}/bin/git-secrets --scan-history";
+      label = ":broom: lint";
+    }
+  ];
+in pkgs.writeText "pipeline.yaml" (builtins.toJSON pipeline)