about summary refs log tree commit diff
path: root/ci/pipelines/briefcase.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci/pipelines/briefcase.nix')
-rw-r--r--ci/pipelines/briefcase.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/ci/pipelines/briefcase.nix b/ci/pipelines/briefcase.nix
new file mode 100644
index 000000000000..d010718a1c19
--- /dev/null
+++ b/ci/pipelines/briefcase.nix
@@ -0,0 +1,14 @@
+{ pkgs, ... }:
+
+let
+  pipeline.steps = [
+    {
+      command = "${pkgs.git-secrets}/bin/git-secrets";
+      label = ":briefcase: Briefcase [lint]";
+    }
+    {
+      command = "nix-build . -I briefcase=$(pwd) --no-out-link --show-trace";
+      label = ":briefcase: Briefcase [build]";
+    }
+  ];
+in pkgs.writeText "briefcase.yaml" (builtins.toJSON pipeline)