about summary refs log tree commit diff
path: root/ci/pipelines/briefcase.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci/pipelines/briefcase.nix')
-rw-r--r--ci/pipelines/briefcase.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/ci/pipelines/briefcase.nix b/ci/pipelines/briefcase.nix
index b01e9f93cb9f..95977ccb9a3a 100644
--- a/ci/pipelines/briefcase.nix
+++ b/ci/pipelines/briefcase.nix
@@ -3,12 +3,15 @@
 let
   pipeline.steps = [
     {
+      key = "lint";
       command = "${pkgs.git-secrets}/bin/git-secrets --scan-history";
       label = ":broom: lint";
     }
     {
+      key = "build";
       command = "nix-build . -I briefcase=$(pwd) --no-out-link --show-trace";
       label = ":nix: build";
+      depends_on = "lint";
     }
   ];
 in pkgs.writeText "briefcase.yaml" (builtins.toJSON pipeline)