about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
new file mode 100644
index 0000000000..916317ea56
--- /dev/null
+++ b/ci-builds.nix
@@ -0,0 +1,17 @@
+# This file is invoked by the CI build and recursively filters the
+# package set for attributes that should be built automatically.
+#
+# Packages can be opted-in to being built by CI by setting
+# `meta.enableCI = true`.
+#
+# TODO(tazjin): Actually implement the above.
+
+let
+  pkgs = import ./default.nix;
+in with pkgs; [
+  services.tazblog
+  services.nixcon-demo
+  tools.kms_pass
+  tools.blog_cli
+]
+